Back to overview
Downtime
South Korea Network Outage
Nov 13, 2025 at 10:52am UTC
Affected services
Seoul, South Korea - (ICN)
Resolved
Nov 13, 2025 at 11:21am UTC
This incident is has been resolved
Affected services
Updated
Nov 13, 2025 at 11:00am UTC
Due to a carrier issue, the upstream link has been removed
Our network team is currently monitoring this issue
Some connections may experience some network improvements
Affected services
Created
Nov 13, 2025 at 10:52am UTC
The entire South Korea PoP network is currently experiencing an outage
Affected services